my dotfiles
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
sentriz e3a3887d90
bin: use abs paths for catt script
11 months ago
conf_common vim: add s* mappings 11 months ago
conf_extra mime: update 11 months ago
conf_phone bin: use abs paths for catt script 11 months ago
conf_server meta: decom second array 1 year ago
docs docs: fix audio bluetooth systemd 1 year ago
hooks meta: run shfmt 1 year ago
.gitignore gitignore: add mpv scripts 1 year ago
.gitmodules vim: upgrade to #12655, delete diagnostic, delete completion 1 year ago
install-common meta: use env for install scripts 11 months ago
install-extra meta: use env for install scripts 11 months ago
install-phone meta: use env for install scripts 11 months ago
install-phone-all meta: use env for install scripts 11 months ago
install-server meta: use env for install scripts 11 months ago
license.md update md case 2 years ago
readme.md meta: remove install scripts 1 year ago
vim-plugin-install vim: add plugin install scripts 1 year ago
vim-plugin-uninstall vim: add plugin install scripts 1 year ago

readme.md

basic stuff

$ install git stow
$ git clone https://github.com/sentriz/dotfiles.git ~/dotfiles
$ cd ~/dotfiles
$ ./install-common  # always
$ ./install-extra   # if gui system
$ ./install-server  # if server

meta stuff

$ # setup git hooks
$ find hooks/ -type f -exec ln -sf '../../{}' .git/hooks/ \;

fish stuff

$ rm ~/.bash* ~/.profile ~/whateverelse
$ chsh -s $(which fish)
$ wget https://git.io/fundle -O ~/.config/fish/functions/fundle.fish
$ fundle install

neovim stuff

$ python3.x -m pip install --user pynvim
$ git submodule update --init # get vim plugins

python stuff

$ # if no pip for pythonx.x
$ curl https://bootstrap.pypa.io/get-pip.py | pythonx.x - --user

extra stuff